Your Website Links Not Appearing Properly In Twitter? Here Is A Fix!

twitter-tools

#1

Just like Facebook’s Debugger Tool we have a similar one for Twitter called “Card Validator”. You can use this to see how your website links will appear in Twitter.

If you are facing any issues with your website link (WordPress), I would suggest you to follow the below mentioned steps:

  1. Go to your Yoast SEO plugin > Social > Twitter

Here you can enable the “Twitter Card Meta Data” option and then pick the ‘card type’ you want.

Even after this, if you are still facing any issue, then you need to edit your robots.txt file for a small tweak.

You can do this via Yoast SEO plugin itself, go to Tools > edit Robots.txt and enter this under your existing code:

User-agent: Twitterbot
Disallow: *
Allow: /wp-content/uploads/*

That’s it. I think this should solve any issues you are facing with your link. Do let us know if you are still facing any issue. :slight_smile:


#2

Hello bro ,

I have tried what u mentioned… when i checked my account Yoast SEO plugin itself, go to Tools >
it says like u didn’t have any Robot.txt file .

below that there is a option like create Robot.txt file i have done that and also the content inside the file is as below

User-agent: *
Disallow: /
User-agent: Twitterbot
Disallow: *
Allow: /wp-content/uploads/*

and i have updated it but when i tried to post the url in twitter remains posted as link only

my webiste url : http://techisfeed.com/


#3

Hi @Viknesh_Unbeatable, I checked one of your blog posts, it’s working properly mate… can you try this link on Twitter and share the result please? :slight_smile:


#4

Awesome mate its works

for the link u used but actually thats a demo content in my blog as the blog is under working

http://techisfeed.com/neeya-naana-dowryepisode/

the above url is the post which is created by me and also this link is not worked and i have checked with card validator and it shows the preview

Finally it Works !!!

It get posted as expected

Thanks alot mate !!! Your are awesome


#5

Best wishes bro. Welcome to the forum. :slight_smile:


#6

Hmmm…Quite interesting and useful too. I never faced this issue.