"Your homepage cannot be indexed by search engines" Yoast Error

yoast-seo

#1

Under Yoast SEO plugin, its showing me an error “Your homepage cannot be indexed”
See the screenshot

However, when I checked search console, it is not shwoing any error.


#2

Sometimes Yoast showing like this error. Don’t simply check your homepage indexed or not in Google.

Search this term on Google
site:www.yoursite.com


#3

By any chance have you enabled this on your WordPress “Reading” Settings? :slight_smile:


#4

It is showing up :slight_smile:www%20lifethroughmybioscope%20com%20%20%20Google%20Search


#5

No No, not at all. One more thing Pradeep> I moved to https few months ago and it was a secure connection but since 2 days, it is showing insecure. What could be the reason?


#6

Change your all http internal link to https