None of the Page Speed Optimization is Working for my site



Recently, I moved to a light weight theme “Newspaper from tagDiv” but strangely I am not getting any better results for it than Loading time being 6 seconds and sometimes 22 seconds with page size being 2mb+

I did try the Page Speed Optimizations according to some threads here but it ain’t working for me and not giving any better results. W3 Cache is always a problem to me (idk why) it made the site to load in 60 seconds!! I did all the things mentioned in the WordPress Optimization thread by @the_mcnaveen but it ain’t working! Only the page speed score gets better and not the yslow or loading time.

Blog URL:-

Can someone optimize my site for me? Plz?

Thank You


Hi @a15, may I know which web hosting service you are using? :slight_smile:


Hey, I am using Vapourhost, but this may not be the problem cause my previous theme wasn’t giving an issue.


Are you using W3 Total Cache plugin mate?


I tried with W3 cache, Wp-rocket, Wp Super Cache and also Autoptimize.

PS :- I tested them separately.


Cool @a15, I want you to integrate Google Page Speed with W3 Total Cache… you can refer this post:

Do kindly try this, and update me the page speed score you are getting, please share a screenshot of that, I’ll definitely guide you further from there. :slight_smile:


Okay sir, I’ll try this method and share a screenshot soon. :slight_smile:


Strangely I can’t see the widget on my dashboard, I am sending a image of the settings in w3 cache.


In your WordPress dashboard, at the top you’ll find something like “Screen Options”, click that and see if you can enable this page speed report via that bro. :slight_smile:


You need to compress images, if you just compress images and test it, you’ll see much improvement in your score, moreover how about removing Alexa rank widget? I don’t understand why many bloggers put it on their site…it does nothing and nobody cares about Alexa rank anymore.

Even though W3 Total cache is the best,you may find it hard to configure it in that case you can try Comet Cache, it’s good to with very less options to set.

All the best!


@a15 Sorry Bro :slight_smile: Just now I back to work. Can you DM in Facebook :slight_smile:

@vapourchirag Are you using some default cache in your host ?


That’s what, It ain’t showing it even there :confused: , that’s why I said it ain’t showing it :frowning:


Thanks for the reply @nikphirke I am currently bulk smushing my images, even I had the same thought and I’ll maybe remove the Alexa widget as it shows no effect.

I’ll try comet cache maybe it’ll work for me. :slight_smile:


Not sure if it helps further, but do try these mate…

###1. Leverage Browser Caching

Add this to your blog’s .htaccess if you haven’t bro. Do check whether something like this already exists as well before proceeding. (Always take a backup beforehand!)

## Leverage Browser Caching ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType text/html "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault “access 1 month”

## Leverage Browser Caching ##

###2. Enable GZIP Compression

You can do this via W3 Total Cache plugin or there are some individual plugins for this.

###3. Optimizing your Images

Images are the real culprit here I guess. Try to remove 1 post from “Latest from Us” section and remove 2 posts from the main homepage section.

###4. Minify HTML and Javascript

This seems to be a huge concern as well, have you done this? If so, how exactly bro?

###4. Additional Tips

  1. Remove the ‘Comments’ count from the homepage, not really that useful for the readers/visitors.

  2. Your logo’s size is huge, kindly reduce it a little bit and optimize it as well.

  3. Remove ‘Login’ from the footer.

  4. See if you are having any broken links on your homepage.


I did try the steps that you’ve mentioned, and the page size has reduced by 1mb, and maybe it’ll reduce more once the images and HTML and CSS are minified. The ss for the current stats is:-

And bro the Logo’s size is 20kb if that’s what you meant. :slight_smile:


No no, I’m just saying it’s kinda big bro, you can reduce the height/width. :slight_smile:

By any chance, you used any redirection code in your .htaccess file bro? Do look into this as well… I feel like your theme is complicated as well, but possible to optimize it further nevertheless!


Ok, I’ll resize the logo and make it small.

There aren’t any redirections in my .htaccess only automatically generated w3 cache’s codes and some general htaccess codes.

The theme is indeed complicated. Should I change it? If yes then which one would be nice and well optimized :slight_smile: I know Genesis and MTS have nice ones, but they look non-appealing. But still, your opinions will be considered :slight_smile:


You can check out Magazine3 themes bro… they are pretty good.

Regarding your current theme, if possible, do check all codes and remove unwanted Javascript bro, this will definitely help to optimize the theme overall. In some of my clients’ websites, I have seen unwanted JS codes for Social Share buttons, removing them helped us to improve it a lot. :slight_smile:


Ok, I’ll check the themes

About Javascript, Idk coding bro and how can I look up for extra JS? :confused:


Not extra bro, but unwanted:frowning: I don’t have a proper guide for this, but you can check out header.php and footer.php… you might get an idea though.