Need help in switching

ssl

#1

Hello,
I was provided SSL certificate by my hosting provider. Being a noob in this stuff, I don’t know what I did, my site got http instead of https. Is there any way to shift to https from http.


#2

Which SSL certificate (company name) was provided by your hosting provider bro? :slight_smile:


#3

I dont know sir,
my hosting provider is Visualcloudx
where can i get that?


#4

Kindly ask your web hosting provider whether they provide any free SSL bro, if yes, ask the service name… if it’s good, we can proceed with that, else we have some alternatives here:


#5

Ok sir, I will ask my hosting provider about it. Well good to know that it is feasible.
I will surely update you tomorrow!


#6

Hello, good morning sir, I didn’t asked my hosting provider yet. But I found that the name of the certificate is
“LetsEncrypt SSL” certificate.


Is it the required information?


#7

Great bro! Can you go to your cPanel and see if you can find an icon named “Let’s Encrypt”? :slight_smile:


#8

yes sir, I found it! Is it a good certificate?


#9

Provide your site URL for the quick investigation.
If you talking about https://www.techymoon.com/
I have checked the site and it’s working fine here with https and here you’re using CloudFlare’s Flexible SSL.
Refer: http://prntscr.com/fsny3p


#10

Do I need to do anything sir? @amit


#11

No need. It’s loading fine with a good speed.

Check: http://prntscr.com/fso00u


#12

@amit
WOW. I see its working fine with https. Sir, How can I redirect all my viewers from any property to https property?


#13

Add following code on htaccess file in root

# HTTP to HTTPS
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

Refer: Resolve Mixed Content Warning


#14

can you guide me where can I get that htaccess?


#16

It’ll be in the root directory bro, go to your cPanel > File Manager (Enable ‘view hidden files’), and you’ll find this one…


#17

Am I the only one who is not able to see htaccess in root folder even after enabling “show hidden files”?


#18

Kindly go to your public_html folder and see please. :slight_smile: Or even if you have Yoast SEO plugin installed, you can access this file by going to SEO > Tools > File Editor and find this.


#19

found it sir…
there is a pre written code.


should i delete it and replace it with the code @amit has given?


#20

No
place the given code just above #begin wordpress


#21

like this…
done!