Mails are going to spam folder

(Rajan Gohil) #1

I run hostinko
I am facing a major issue, most of my mails are going to spam folder :confused: idk what to do now…
Even confirmation mail and other mails are going to spam folder. I have to change domain or IP or what?

(Pradeep Kumar) #2

What’s that email address bro? Which service you are using? Gmail or G Suite or? :slight_smile:

(Rajan Gohil) #3

We are using this email address:
we are using Yandex

(Pradeep Kumar) #4

Do check whether you have configured SPF (Sender Policy Framework) and DKIM (Domain Keys Identified Mail) records for your domain name mate, if not, do this and I’m sure this will fix your issue more or less. :slight_smile:

(Rajan Gohil) #5

Lemme try that…
Would love if you :no_mouth: try and test it :slight_smile:

(Pradeep Kumar) #6

Sure mate, you can send an email to, will update you! :slight_smile:

(Shivam Saluja) #7

Hello Mate,

I took the liberty to check your DNS records -
It looks like your SPF and DKIM records are not setup properly.

To get your email directly to Inbox, Please set your DKIM and SPF records properly and keep sending good emails, believe yours will be transactional emails only, since it is a Hosting company, As long as someone else hosted on the same IP is not sending any spam emails, You email should start landing directly to Inbox within next 24 hours.

Also here is a great tool, to send a Test email- www(.)mail-tester(.)com (Since I can post only one link)
Since you are using WHMCS, you can simply create a Support ticket to the given email and check your sender score, and then improve it according to the above instructions.

Let me know if you need any other help.

Shivam Saluja

(Rajan Gohil) #8

Thanks buddy, Will try it out.

(Dinesh Yadav) #9

@Technopope thakns for the info,
i have tried this, mail tester says score of 7.77 and all fields are ok except DKIM, how can i set this also, i have already enabled DKIM support in mail account in VestaCP.

(Pradeep Kumar) #10

Which platform you use for your Emails mate? :slight_smile:

(Dinesh Yadav) #11

@pradeepkumar just now i did it, now it is fully secure with DKIM now, using roundcube default. it was a permission issue on “dkim.pem” file in exim configuration.

(Shivam Saluja) #12


I am sorry for being delayed, I hope your issue is resolved. If not you can always respond and let me know if there are issues still existing.