How to fix handshake failure?

wordpress-errors

#1

Help me to get rid out of this Problem. When I try to submit my blog on Alltop but it says you need to enter valid Feed URL.
Then I checked my Feed URL https://www.tricksfolks.com/feed in FEED Validator but shows this error

Server returned [Errno 1] _ssl.c:504: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

I am Using CloudFlare and one more thing my blog’s feed URL perfectly working.


#2

Hi @Pruthvi, which SSL you are using for your website mate? :slight_smile:


#3

Comodo SSL bought via Namecheap


#4

I’m not sure about a perfect fix for this bro, but kindly try this!

Go to your root directory > /wp-includes/functions.php and add this code there:

curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false)

Kindly take a backup of that file before proceeding further, just in case if any error occurs. :slight_smile:


#5

Not working. After adding this code site goes down totally:sob:.


#6

I’m sorry man, I thought this might help. :frowning: Can you try adding your RSS Feed to any other blog listing website or any website and let me know if you still face the error? Meanwhile, can you try adding like this instead on AllTop:

http://www.tricksfolks.com/feed

I removed ‘https’ and replaced it with ‘http’ here. :slight_smile:


#7

Let me tell you this,

If you use Cloudflare with other SSL in your case it’s from (Comodo SSL bought via Namecheap) that means the Comodo SSL bought via Namecheap will only protect the connection between your server and CloudFlare. The connection between the public and CloudFlare will be protected by one of CloudFlare’s certs.

To solve this, you must have Full SSL (strict) enabled on CloudFlare’s dashboard.
Unfortunately, it’s not included in the free plan. You can either upgrade to Enterprise plan or generate CloudFlare’s SSL Certificate and install it on your server.

Thank you for your understanding.


#8

Hey Amit,

You are correct, His feed is not working because he is using Cloudflare’s SSL.

However, Full(Strict) mode for SSL is available for Free customers aswell and using Full(Strict) means it will validate the certificate between Server and Cloudflare. it has nothing to do with changing the SSL on front-end.

To solve his issue, he will have to disable Cloudflare or he can purchase SSL directly from Cloudflare which is 5$/month. Changing to Full(Strict) is a not a solution and it won’t work.


How to make a custom email in mailchimp? need your help bloggers!
#9

Yeah, thanks for the correction.


#10

Did you got the solution for this bro.
As I am facing the same issue. I am using cloudflare and my own SSL. But cloudflare’s didn’t allowing to turn off the ssl and when I am turing on the ssl it is showing me the same Feed error in FeedValidator.

Even, I have tried to use the SSL of cloudflare on acc as well as on my server. But the error is same. :frowning:
:disappointed_relieved: This is really very irritating for me.

@amit @Technopope Please help me out with this problem if you have solved this issue :pensive: